Suite

Comment exclure les valeurs nulles ou nulles de la classification des couleurs graduées ? ArcGIS 10.3

Comment exclure les valeurs nulles ou nulles de la classification des couleurs graduées ? ArcGIS 10.3


J'ai un calque qui est classé à l'aide de couleurs graduées. Je l'ai mis à une classification manuelle avec 7 niveaux.

Ma 1ère valeur de 0 n'est plus nécessaire. Comment supprimer le 1er niveau de classification. Pour que ma classification manuelle commence à 0,000001 -1000000.000000 ? Pour que cela ressemble à quelque chose comme…

J'ai essayé de modifier mes valeurs de rupture pour commencer à 0,000001. Mais l'échelle commence toujours à 0,000000.

J'ai également essayé d'utiliser l'exclusion de données pour exclure NULLS et 0, et j'ai le même problème, la valeur 0,000000 reste.

De plus, lorsque vous cliquez avec le bouton droit sur le premier niveau 0,000000 et que vous sélectionnez Supprimer les classes, le niveau suivant passe à 0,000000 - 100 000 000 000… ce que je ne veux pas, je ne veux pas. Je veux que la valeur 0,000000 soit exclue.

Avez-vous des idées sur la façon d'exclure la valeur de 0,000000 et de faire démarrer mon échelle à 0,000001 ?


Je suggère d'effectuer une requête de définition sur la couche. L'expression sera quelque chose comme ceci :

[<>] > 0

Cela exclura tous les enregistrements avec des valeurs nulles/zéro dans la couche et également dans la légende.


Je jouais juste avec cela et il semble que lorsque vous utilisez l'exclusion de données, cela exclut les données (dans ce cas 0), mais les répertorie toujours dans les colonnes de plage et d'étiquette. Mes suggestions seraient de modifier manuellement la colonne d'étiquette pour lire ce que vous voulez qu'elle lise (cliquez sur le texte de l'étiquette dans l'onglet symbologie). Vous pouvez vérifier que les données 0 ne sont vraiment pas affichées en ajoutant à nouveau la couche et en la symbolisant pour simplement afficher les données 0, puis confirmer visuellement (vérification ponctuelle) qu'elle est bien affichée dans la couche d'origine. J'espère que cela aide un peu.


J'ai rencontré un problème similaire et je l'ai résolu par une requête de définition : effectuez une requête de définition sur la couche en cliquant dessus avec le bouton droit de la table des matières, accédez à Propriétés, choisissez Requête de définition, Générateur de requêtes, sélectionnez le champ d'étiquetage et définissez-le xxxx > 0. Refaire le classement.